This topic contains 9 replies, has 2 voices, and was last updated by  Hans (Support Admin) 1 year ago.

Blog only shows post titles

  • Hi,

    I have a site with a Page “blog” to display the posts (like in your demo)
    The problem I have is that when clicking on “blog” in the menu, the page only shows the title of the post. I can’s see how to set it up so that the title, full text and featured image are shown (like in your demo)

    Thanks in advance for your help

    Best,

    Ruben

    Hello Ruben,

    The Blog (Posts) page shows a archive of your latest posts.

    It should show the post thumbnail (if you uploaded one), title and excerpt.

    Make sure you uploaded a image for the post thumbnail otherwise none will show.

    When you click on the title of a post it will then take you to the single page for that post.

    Hi,
    Sorry, but your answer makes no sense to me. (It must be my fault, for sure 😉 )

    This is a screenshot of what I was referring to in your demo.

    screenshot of demo

    The top main menu option “blog” in your demo opens a page which shows three posts (Img, title and excerpt). I have a top menu, too. I have a “posts page” (where posts should show), and I have some posts. The problem is that mi “posts page”, the one I accede through the top menu, only shows the title of the posts.

    I hope you understand what I mean

    Ruben

    Sorry, the screenshot doesn’t show. It’s here:

    http://imagizer.imageshack.us/a/img923/4018/UTbFnh.jpg

    Hi Ruben,

    Create a page and title it “Blog”.

    Then go to Settings > Reading and set that page as the Posts page.

    Then go to Appearance > Menu and add that page to your menu.

    Hi Hans,

    There’s the rub! That’s the problem. I did what you say but when I click on blog, the page ‘Blog’ ONLY shows the post titles. Nothing else! (the titles are linkable and they lead you to the complete post, though).

    🙁

    Ruben

    PS Thanks for your help, and on a Sunday!! Don’t you Canadians need a break?? Take your time, enjoy the weekend. It’s not an emergency for me.

    LOL it’s ok I’m a workaholic 😉

    Can you send me a link to your website and admin access as well so I have a look?

    Select “set as private reply” when you respond.

    Now it works!

    I just reset some settings (toggled off/on) the Integral Options > General settings > blog/posts settings, which I thought just affected the homepage blog section, but it played the trick.

    Thanks anyway for your help, Hans.

    Best,

    Ruben

    PS Maybe the theme just heard that the boss was coming…

    But I’d love to know how to make the excerpts longer, or even, get the whole post.

    Hello Ruben,

    Glad you figured it out.

    For the excerpts there is a setting in Settings > Reading entitled For each article in a feed, show:

    You can pay around with that.

You must be logged in to reply to this topic.