This topic contains 9 replies, has 3 voices, and was last updated by  Hans (Support Admin) 2 months, 1 week ago.

Cannot change footer content "There was a problem with your action."

  • I am trying to edit my existing footer in the Integral Pro theme, but ever time I try to save the change to the footer component, I get “There was a problem with your action. Please try again or reload the page.”

    I disabled all plugins (except redux since I need it to get to the editor). Still same error.

    Is there somewhere in the database where I could just edit the footer text manually and bypass the redux editor?

    Hello,

    Could you please share with me (temporary) administrator credentials to your site?

    Don’t forget to mark reply as private.

    Thanks,
    Piotrek

    This reply has been marked as private.

    Hello Bobby,

    Is there any particular reason why your WordPress URL is set to https://learnsfdc.com/blog (which is different than Site URL)?

    That might be the problem, as admin-ajax.php is not loading (“Failed to load resource: the server responded with a status of 403 ()”).

    I’ll get back to you with the information about the DB update solution.

    Thanks,
    Piotrek

    Could you also try disabling all CloudFlare cache/performance/security settings?
    It is possible that CloudFlare is blocking access to admin-ajax.php (You can see CloudFlare error in JavaScript console when trying to save footer options).

    Thanks,
    Piotrek

    I am sure there is a reason, but I cannot recall why at the moment, but I’m fine with just updating the content of that footer directly in the DB or file where it is stored if you can point me to the right place. I couldn’t locate it myself.

    I have locked down access to a lot of directories on my site lately due to heavy hacking attempts, so I may have made a directory read-only that needs to be writeable for this content to be updated. That may also be what is causing that 403 error.

    I have now paused Cloudflare. I did attempt this earlier with both Cloudflare paused and Wordfence disabled and it still would not save, so I doubt it will make the difference.

    Hello Bobby,

    You can also just edit the footer.php file. As you can not update the footer text in Integral settings, you might want to customize 28th line of that file (<?php echo $integral[‘copyright-text’]; ?>).

    I hope the above is useful to you.

    Cheers,
    Piotrek

    I can try that, but won’t that get overridden when the theme is next updated?

    Hello,

    Yes that is correct. However, you can always install the Integral Pro Child Theme.

    To download it go to Appearance > Setup Integral and select the Child Themes tab.

You must be logged in to reply to this topic.