This topic contains 9 replies, has 3 voices, and was last updated by  hestia 2 months ago.

Facebook images and post title problems.

  • When sharing on Facebook, the featured image does not display. The only information in the preview is the website URL which does link to the correct post. When I run it through the FB Sharing Debugger I get the following:

    The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.

    I have tried plugins: Add Facebook Share Thumbnail + Meta; Thumbnail Fixer for Facebook; and YoastSEO. Thumbnail Fixer provides a preview function when editing the post which looks great. Unfortunately, it doesn’t work.

    Where do I go from here?

    Thanks.

    Gerry

    Forgot to include website: http://www.landrethonline.com

    Thanks.

    Hi Gerry,

    One of those plugins should work.

    The only issue is that your page is cached by Facebook.

    So you will need to clear the cache before checking again.

    Here is where you can do that

    https://developers.facebook.com/tools/debug/

    Let me know if that doesn’t work.

    I’m just now doubling back to this. The culprit was the SSL certificate. I contacted tech support at Bluehost and they corrected the problem in just a few minutes.

    With FB Thumbnail Fixer, everything is working OK. I’ve had to run all of my posts through the FB debugger but it went quick.

    Thanks again.

    Gerry

    Hello Gerry,

    Thanks for the follow up.

    Yes I can see how the SSL would affect the URL’s recognized by Facebook.

    Glad to know you figured it out 🙂

    hello

    i have the same exact problem since forever now, and it was not even fixed with “Thumbnail Fixer for Facebook” plugin at all.

    before the plugin i had these errors:

    “The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.”
    “The following required properties are missing: og:url, og:type, og:title, og:image, og:description, fb:app_id”

    and after the plugin:
    “The provided ‘og:image’ properties are not yet available because new images are processed asynchronously. To ensure shares of new URLs include an image, specify the dimensions using ‘og:image:width’ and ‘og:image:height’ tags.
    Learn More: https://developers.facebook.com/docs/sharing/best-practices/#precaching
    “The following required properties are missing: fb:app_id”

    so how could i get it working.

    thanks

    Hello @hestia

    Since this issue pertains to the plugin you are using you will need to contact the plugin developers directly.

    Here is a direct link to their support forum,

    https://wordpress.org/support/plugin/facebook-thumb-fixer/

    They should be able to help you.

    well, not really because i even posted the debug errors before trying the plugin that should have fixed the error with the Verb Pro theme. but it did not fix anything, only gave a different error

    The issue you are experiencing is not related to the Verb Pro theme.

    It is a separate functionality from the design of the website. Themes only provide a design to your WordPress site.

    Here is another plugin you can use to add Facebook Open Graph tags to your WordPress site.

    Open Graph for Facebook, Google+ and Twitter Card Tags

    well, that plugin still gives these 3 errors :s

    Inferred Property:
    “The provided ‘og:image’ properties are not yet available because new images are processed asynchronously. To ensure shares of new URLs include an image, specify the dimensions using ‘og:image:width’ and ‘og:image:height’ tags. Learn More”

    Extraneous properties specified:
    “The following properties are specified on the webpage but NOT supported for the specified ‘og:type’: article:published_time, article:modified_time, article:section”

    Missing Properties:
    “The following required properties are missing: fb:app_id”

You must be logged in to reply to this topic.