This topic contains 17 replies, has 3 voices, and was last updated by  spanknet 2 months, 1 week ago.

Graphic problems with master slider plugin (Integral Pro)

  • Good morning
    we have bought integral pro template, but I’ve found a graphical error with master slider plugin, but only in the page of the first link of the top menu.
    I’ve made some template of the original pages with masterslide slide because I needed a slider in all the pages.
    This is an example code of my page is below:


    <?php
    /**
    Template Name: Professionisti
    * Temaplate di pagina con slider
    * @package WordPress
    * @subpackage Integral
    * @since Integral 1.0
    */
    ?>
    <?php get_header(); ?>
    <?php masterslider(19); ?>
    <div class="container">
    <div class="row">
    <div class="col-md-12">
    <div class="content">
    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>
    <div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    <h2 class="entry-title"><?php the_title(); ?></h2>
    <div class="entry">
    <?php the_content(); ?>
    </div>
    </div> <!--post -->
    <?php endwhile;?>
    <?php endif; ?>

    </div><!--content-->
    </div>

    </div>
    </div>

    <?php get_footer(); ?>

    This is the firs error I’ve found (only in the first underlined link), the footer is not in full witdh and there is a navigation bar at the footer side but only in this page, and it’s so strange
    Error footer

    The second problem is that the master slider plugin resize (and crop) my slides starting from the botton, as you can see in these images.
    This is the correct size
    correct size

    This is the crop error at lower resolutions
    foto

    I’ve search for a solution but didn’t found nothing in master sliders options.
    Is there any way to crop and resize the images starting from the top and not from the bottom?

    these are master slider options (all images are at 1800×600 pixel original resolution)
    master slider options

    Thanks in advance for support and sorry for my english!
    Best regards!

    Hello there,

    Thanks for using our theme, we also really appreciate your feedback.

    Could you upload your image attachments somewhere else, as current host doesn’t seem to work right now.

    Thank you,
    Piotrek Bąk

    Hello,
    sorry for the mistake, I’ve uploaded images in other ftp (website is not published yet)

    This is the first error I’ve found (only in the first underlined link), the footer is not in full witdh and there is a navigation bar at the footer side but only in this page, and it’s so strange
    Error footer

    The second problem is that the master slider plugin resize (and crop) my slides starting from the botton, as you can see in these images.
    This is the correct visualization
    correct size

    This is the crop error at lower resolutions
    foto

    I’ve search for a solution but didn’t found nothing in master sliders options.
    Is there any way to crop and resize the images starting from the top and not from the bottom?

    these are master slider options (all images are at 1800×600 pixel original resolution)
    master slider options

    Thanks in advance for support

    Hello,

    thanks for updating the images. Could you please share with me (temporary) administrator credentials to your site?

    Don’t forget to mark reply as private.

    Thanks,
    Piotrek

    This reply has been marked as private.

    I think I’ve found a bug, when I insert a “& nbsp;” in the homepage at down page apperas the horizontal scrollbar, without “& nbsp;” it not appears,

    this is the first code of my homepage:
    & nbsp;
    <h4>Benvenuti nel sito dello Studio Legale Falcon</h4>
     

    Per proseguire, è sufficiente selezionare dal menu in alto una delle voci:
    etc.
    `

    with   there is the error scroll bar like this
    Do you know how to fix it?

    • This reply was modified 2 months, 2 weeks ago by  spanknet.
    • This reply was modified 2 months, 2 weeks ago by  spanknet.
    • This reply was modified 2 months, 2 weeks ago by  spanknet.

    with internet explorer (11) I don’t have the problem with down scroll bar and the page is show correctly, with mozilla and chrome it appears

    Hello @spanknet

    The issue you are experiencing is not a crop error.

    The header is fixed to the top of the screen, so when you narrow the screen size your logo and menu cascade onto 2 rows and cause the height of the header to increase.

    Also, you should disabled the “auto-height” option in the Slider Settings and set a fixed minimum height.

    As for the first issue you mentioned with the horizontal scroll bars, http://www.spanknet.it/img/errore_navigation_bars.png

    If you have entered HTML characters where they should not be this may be the cause.

    I would suggest disabling ALL your plugins until the problem goes away then you will have identified the culprit.

    Lastly, it would be much easier to debug if we had access to the site you are working on.

    My IP is 184.160.238.179

    Most of your issues are not bugs but configuration issues.

    Where are you inserting this code “& nbsp;”?

    If you are inserting it in a title field that would be the cause of the issue.

    Hello Hans,
    thanks for reply,
    I’ve added your ip so you can see the website

    & nbsp; is inserted in the home after H4 tag closed, not in the title.
    Without “& nbsp;” the lower scrollbar disappear in the home

    I’ve also asked to master slider support forum and they gave me a tip, to add a custom code on the slide
    .master-slider-parent { margin-top: 30px; }
    so it seem better

    My screen resolution is 1920×1080 px (full hd monitor)

    Hello,

    I would suggest you use single line breaks instead of “& nbsp;”

    Like this https://www.w3schools.com/tags/tag_br.asp

    Hello Hans,
    I’ve tried insert br tag but it will automatically transformed in nbsp tag! :(
    very strange!!

    tag inserted

    transformed

    these are the plugins installed

    Hello @spanknet

    The issue you are having is not theme related.

    You can try disabling the TinyMCE Editor plugin to see if that makes a difference.

You must be logged in to reply to this topic.