@ahailey

Make sure you are customizing that section in your admin panel on the Integral Options tab.

Not APPEARANCE > Customize.

Once you have activated and configured the homepage’s one-page layout, that is where you must customize the site.

Admin Panel > Integral Options > Contact Section.

Also, please make sure you are running the latest version of Integral Lite, which is v1.1.6.

We fixed that issue in a past release.