Thank you Hans! The Welcome page actually was disabled in the Homepage Layout! Cheers!