Please have a look at this solution, it seems to have fixed the issue for several users.

All on Godaddy hosting accounts.

https://wordpress.org/support/topic/contact-form-7-and-godaddy-hosting-solution/

After setting up your new email address, in GoDaddy go to Account > Web Hosting and click manage.

Under Email go to MX Entry.

Change the option “Local Mail Exchanger” to “Remote Mail Exchanger”

Wait about 15 minutes.

This worked for me and now all emails sent through WordPress hit my inbox correctly, including contact forms.