@RMC

You will need to configure your permalinks.

Go to Settings > Permalinks and select Post Name option.

That will fix the issue.