Hello @stefania,

WordPress need at least PHP 5.6 to work properly. I am sure that upgrading to 5.6 will resolve your issues.

Cheers,
Piotrek