Hello Rachel,

Please keep in mind there’s the default header image and the header image when the one-page template has been configured.

In your Admin Dashboard go to Parallel Options > Welcome and set the background image there.

Make sure you have completed the first 2 steps outlined in Appearance > Setup Parallel.

Let us know if that doesn’t fix the issue.