Go to Appearance > Customize > Blog/Post Settings.

You can disable the Author Profile.