Hello @brinkhus

Ok, I see the issue on mobile.

You are using the Master Slider.

You need to set a height and min-height for mobile in the slider settings.

When editing your slider click on the Settings tab.