Hello,

Add the following CSS code to the Custom CSS field of the Custom Code section in the Integral Options panel. That should do it.

.projects-grid .grid {
overflow-x: visible;
}