I like what you’ve done with the theme, nice colors.

Yes I see what you mean.

You can adjust the padding for mobile devices if you increase “padding-top” to 30-35% it will fix the issue.

Here is the code you need,

@media (max-width: 480px) {
.hero {padding-top: 34%;}

Add this code in the Custom CSS field of the Integral Options > Custom Code section.

If you have any issues let me know.