Embed YouTube video (responsive)

  • Hi.
    I was wondering if you could help me figuring out how I could get an embedded video to be responsive in your theme.
    Some of the menus allow for HTML, so you can embed an iframe from YouTube into it.
    However, putting on either a standard size, which is too large for smartphone screens or a small one, to be compatible, it’s downright ugly on a desktop or laptop.

    And as the rest of the theme is so lovely responsive, I really don’t want to ruin the overall design by adding such a video.
    I’ve found YouTube guides on how to use specific CSS code to make it responsive, however I can’t seem to find out how to make it apply to the theme.

    I have a feeling that the custom CSS is a pro feature?
    Because even though I add it in the themes CSS in the custom CSS section, I can’t seem to create a new class that it recognizes and makes the video responsive.

    I’m not a programmer.
    I learned basic HTML then CSS was this new thing, so I find it easy to “read”, however I only have a vague idea of how little I actually know XD

    I’ve been fiddling with this for a little over 4 hours straight.
    I hope you can help me.

    • This topic was modified 4 years ago by Ronex.

    It will be easier for you to use a plugin to do what you want.

    Here is a Google search will several results which can help you,

    https://www.google.ca/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=wordpress%20responsive%20video%20embed

    Here is a plugin you can use https://en-ca.wordpress.org/plugins/advanced-responsive-video-embedder/

    I had done the Google search myself, but thank you anyways 🙂

    I had no idea if the plugin would work with your theme or not, and in any case, which ones would work then.

    In the mean time though, I figured out how to do it without a plugin.

    I simply wrote it as a HTML document from scratch, with body, style and everything, in which I could integrate the CSS commands, that somehow got overwritten, when added to the theme’s CSS code.

    In other words it works now 🙂

    • This reply was modified 4 years ago by Ronex.

    @ronex

    Ok, good to hear it is solved.

You must be logged in to reply to this topic.