How to override blog default

  • Hi,

    As I can see in your demo (Integral Pro), when you click on “blog” in the top menu you get summaries of the posts:
    + featured image
    + Title (linkable to the entry if you want to read the full post)
    + date, category, comments…
    + An summary of the post in plain text even if styles have been applied to it (bold, italics, links…) or images have been inserted.

    What I’d like to get, though, is the following:
    When I click on “blog” in the top menu, I would like to get the FULL posts, but I can’t see how to do it. Whether I set SETTINGS->Reading to “Full text” or to “Summary”, it makes no difference. I only get the same as in your demo.

    Is there a way to show all the posts with FULL TEXTS when I click on “blog” in the top menu?

    Thanks in advance for your help.


    Rubén Valero

    Hi Ruben,

    Yes you can.

    Create a new page and entitle it “Blog”, no content.

    Save it.

    Then go to Settings > Reading and set that page as the page to display posts.

    Then go to Appearance > Menu and create a menu item using that page.

    That should do it.

    Hi Hans,

    I’m afraid that doesn’t work. I followed your instructions (actually, I’d already tried that) but… no way. When I click on “Blog” on the top menu, I still get the same as in your demo:
    + Featured image
    + Title (linkable to the entry)
    + date, category,…
    + Posts in plain text (no links, no styles, no images).

    If there’s any other thing I could do (I mean, somewhere in the php code there must be a function that filters the content of the posts and reprint them with no styles, no images)…

    And please, don’t work on Sundays! It’s not an emergency at all!



    Hello Ruben,

    Ok, maybe I didn’t properly understand what you meant.

    Now I think I do.

    Go to Appearance > Editor and select the index.php file.

    Around line 52 you will see


    replace that with


    Let me know if that doesn’t work.

    Hi Hans,

    Yes, that’s what I was trying to find out. It works now!
    Thanks a lot for your answer.



    PS I understand the index.php file may be replaced when there’s an update of the theme so I’ll have to replace that code again, right?


You must be logged in to reply to this topic.