logo in header not responding on mobile Chrome (Android)

  • I’ve noticed since the latest update to Integral Pro, the logo in my header is not responding to the screen size on mobile (Android) https://goo.gl/photos/WYJWBgG7MQDyuSv56 but only in Chrome – it looks fine in Firefox.

    I also notice that if I try and load a non-existent URL to bring up a 404, the logo responds correctly on the 404. https://goo.gl/photos/vt2RABFU3BbnSc6EA Interior pages also look OK. This led me to assume it was a caching issue, but I just tried on a separate device that has never loaded the site, and it too loads incorrectly.

    I’m stumped! I’ve tried deleting and re-adding the image. Any ideas?

    • This topic was modified 3 years, 4 months ago by jjsararas. Reason: realized interior pages also fine, it's just the homepage
    This reply has been marked as private.

    Hi @jjsararas

    I just checked your site (the homepage) on a mobile device and the logo is responsive (it is smaller).

    The problem i actually the width of the Submit button in the contact section.

    Look at line 1217 of your style.css file. The width is 40em.

    Change that to something smaller for mobile phones in the media queries at the bottom of the style.css file.

    Or remove the width attribute.

    That is causing your page to be larger than the screen width on mobile devices. Which is affecting your logo.

    Thanks, that worked. A bit strange tho- I never changed that code, that’s how it is in the theme’s original style.css file!?

    Hello @jjsararas

    You are correct, it’s a bug.

    I fixed it and will be adding it in our next update.

    Thanks for pointing it out 🙂

    bug bounty = uno cerveza 🙂

    it still behaves strangely tho, loads just slightly too wide – with the edge of the menu burger just barely falling off-screen. But then as your scrolling up and down the homepage, it all snaps into place and magically corrects itself.

    these two images were taken without clicking any link, just scrolling up and down the homepage: https://goo.gl/photos/VUFPiyPvyhk63NHi6

    I’m not too worried about it tho, I’ll see what it looks like after the next update 🙂

    Hello @jjsararas

    Salud! https://www.dropbox.com/s/nxbfpse4zeeiw03/cerveza.jpg?dl=0

    I checked your site and I see what you mean.

    When you scroll down the page the issue eventually goes away.

    Your logo and menu is not the issue.

    Try disabling the animations just to see if that could be the cause.

    Yep, I think that’s it. Disabled animations and I can no longer reproduce the behaviour.

    OK, let me see if I can replicate that issue on my end.

    It’s most likely a silly CSS conflict.

You must be logged in to reply to this topic.