This topic contains 14 replies, has 2 voices, and was last updated by  andyro 5 months ago.

Master Slider Vert Dimension

  • I’m wondering if there is a way to let the slider for the single project slider adjust to the image size in the gallery? There seems to be a max. vert dimension that is in effect cropping the square images I am trying to display – see: https://www.thomsonarchitecture.ca/#work Thanks.

    Hello Andy,

    The images are not restricted to a specific height.

    You just need to crop and resize the images so they all have the same dimensions.

    Then the problem will be resolved.

    Let me know if that doesn’t help.

    What is happening is I have 3 large square images that the bottom 1/3 or so are getting cropped by the slider – try it with an image that is like this: https://www.thomsonarchitecture.ca/wp-content/uploads/2019/03/Solar-Q-2.jpg

    And you will see what is happening on my single featured image slider – at first I only had 3 square images just like this one – all the same size and they seem to get cropped – is this a function of the area allowance for that block of the site?

    A

    Hi Andy,

    Ok, I see what you mean.

    Can you provide me with admin access so I can have a look?

    This reply has been marked as private.

    Hello Andy,

    I have added some custom CSS which prevents the slider from cutting off some of the images.

    In your Admin Dashboard go to Integral Options > Custom Code > Custom CSS and you will see the code I added.

    Awesome, thank-you

    Hans – on the note of the slider, as per this blog post: https://www.thomsonarchitecture.ca/2018/11/20/how-many-miles-per-gallon-does-your-building-get/

    Is there a way to get the master slider or whatever you are using as a lightbox, to open all images in the lightbox so it’s not limited to the single page format’s grid gallery images? Images now open a link to the image in a new page, rather than using a lightbox effect.

    Hello Andy,

    Are you referring to the images within the post?

    When I clicked on them they opened in the lightbox, not in a new tab.

    That’s because I’ve got the photonic plugin running but now it’s opening 2 images at the same time when one image is clicked on the homepage :[

    From the photonic plugin author: I asked if I can disable photonic’s actions on the homepage only, answer is no (see in quotes below). In that case is it possible to disable the flex-slider on the Integral side to see if that resolves the doubled lightbox issue on the homepage grid gallery? The reason is the photonic plugin is free, well supported, and excellent at serving files hosted on image sites like google photos, smugmug, flickr, etc. I plan to lean on it heavily for future blog posts and project portfolios… so I’d like to find a solution for the conflict.

    “The short answer to your question is no, you cannot disable Photonic on a specific page.

    At this point I am seeing a slew of JS errors on your site due to jQuery going missing. I am not sure if this is a problem with your site, or if it is because of my trying this from China (it looks like the whole WP CDN is blocked out here). As a result I am not able to troubleshoot this successfully, however I will be back in the US on Sunday and I can take a look then.

    In the meanwhile here are some pointers: Photonic will not disable another plugin’s lightboxes; the only thing you can do is disable Photonic’s own scripts. By default Photonic does not target non-Photonic galleries. So if you have got a gallery or slider from a different plugin Photnic will not touch it. It looks like on your site you have FlexSlider and Master Slider (apart from Photonic), so it is possible that those are conflicting internally.”

    Hello,

    I checked your site again and I see the issue with the double modal popup in the Project Grid section.

    Our theme uses Pretty Photo for lightbox popups. Which is build into the theme.

    If you are using a separate plugin for that with the same trigger (the plus sign) then you’ll have them triggered twice.

    What you can do is disable Pretty Photo in our theme by add two forward slashes before the line which enqueue the file in the enqueue.php file located in the /inc folder.

    Go to Appearance > Editor and select the inc folder then the enqueue.php file.

    Here is a screenshot of the line you need to comment out.

    https://www.dropbox.com/s/9i4y3iisdo6ova1/integral%20disable%20pretty%20photo.PNG?dl=0

    Hmmm.. I tried commenting out line 19 of the inc/enqueue.php as you recommend but the behaviour seemed to persist even when I cleared cookies and even when I ran a different browser. Are you able to take a look with the login provided before by PM? Sorry for the hassle – I tried a few times…

    Hello Andy,

    I logged in and checked your enqueue.php file and the line was not commented out.

    So I did it for both the CSS and JS files for Pretty Photo on lines 12 and 19.

    Now only 1 image lightbox is triggered.

    Sorry I must have missed the CSS screenshot. I had only tried commenting out the enqueue.php file. Thank you!!!!

You must be logged in to reply to this topic.