Menu is wrongly active

  • Hey

    When I go to the homepage of my website it shows always the first entry in the menu as active. But this is wrong, as the first entry of the menu is linked to a category and not to the homepage. How can I turn this off?
    Interestingly, when I scroll down the homepage a little bit, it turns of the active tag.

    Hello @Staedi

    Can you provide a link to your site so I can have a look?

    This reply has been marked as private.


    The menu is working as it was intended.

    When viewing a section, the menu item for that section will be underlined.

    So the first section you have on your website is the Blog section with the latest posts.

    Which is why the “News by Stama” menu item is underlined, because that is the first section on the home page.

    If you view the demo for the theme you will see how it works.

    If you don’t want this you can use a bit of CSS code to hide it.

    Use the following code in the Custom CSS field of the Custom Code section in Integral Options,

    .navbar-default li a:hover, .navbar-default .navbar-nav > a, .navbar-default .navbar-nav > li > a:hover {
    border-color: #fff;

    Thank you for the immediate support.

    Okay, I probably got something wrong… As I set the reading settings for the posts page to the site “blog” and the menu item “alle Beiträge” is actually the link to this site, I assumed this menu item is supposed to be active.
    Is there a way to do that?

    Hello @Staedi

    I’m sorry but I do not understand exactly what you mean.

    I understand there may be a language barrier.

    Maybe if you write in your native language and use Google Translate to translate into English.

    Okay I try another approach…

    I removed now the blog section from the homepage but the first item in the menu “news by stama” is still active! But this shouldn’t be as the first section is the newsletter section….

    Hello @Staedi

    You can implement the CSS code I gave you in an earlier message and the red underline will disappear.


You must be logged in to reply to this topic.