Need better parallax control

  • Hello. Parallax is currently rolling at the wrong speed, not giving the true parallax feel. It scrolls up faster than the overlaying content, but it should scroll slower (because it’s a background).

    Also, the bottom edge of the background image is revealed when scrolling down the page, because of this.

    Hero Unit
    Call To Action

    Please provide a fix.

    You can control the speed of the parallax effect in the sections/custom.php file on line 14-17.

    It is currently set to 0.4, you can change to whatever you want.

    We will be adding controls for this in a future release of Integral Pro.

    It doesn’t make sense. It’s set to 0.3 (Integral Pro 1.2.8) which would mean that it should move at 30% scroll speed in relation to the page itself.

    But it’s actually moving FASTER than the page. This gives it a weird feeling, it’s not the correct parallax effect.

    Actually, you get the desired effect if you set the speed to NEGATIVE 0.3:

    <?php if($integral['hero-parallax-toggle']==1) { ?> $('#welcome').parallax("50%", -0.3); <?php } ?>
    <?php if($integral['testi-parallax-toggle']==1) { ?> $('#testimonials').parallax("50%", -0.3); <?php } ?>
    <?php if($integral['calltoaction-parallax-toggle']==1) { ?> $('#calltoaction').parallax("50%", -0.3); <?php } ?>
    <?php if($integral['newsletter-parallax-toggle']==1) { ?> $('#newsletter').parallax("50%", -0.3); <?php } ?>

    This is indeed a parallax effect. There is no CORRECT parallax effect, it’s simply a choice of how you want the effect to behave.

    Using negative values as you have pointed out is also an option.

    Okay, maybe there is no ‘correct’ parallax effect, but surely you didn’t mean to wrap the background image to expose its borders? That only happens because it scrolls faster than the page. Setting it to a negative value makes sure your demo content doesn’t break. I guess it ultimately depends on your image’s resolution.


You must be logged in to reply to this topic.