Newsletter Form

  • Hello i’m having some trouble getting the newsletter form to work I’ve downloaded the mailchimp plugin and set it up but i can’t work out how to get the actual form to work?

    Thanks

    Hello @candybuddy

    Hopefully this will answer your question, http://support.themely.com/knowledgebase/configure-homepage-sections/

    Scroll down to the Newsletter Section (towards the bottom).

    If that doesn’t help you, please let me know.

    thankyou i’ve managed to get the form working now. Is there any chance you could help me with changing the the style of the subscribe button i would like it to look like the transparent button with a white border.

    Yes I can. Please provide me with admin access to the website and I will do it for you.

    Make sure to select “Set as private reply” when replying.

    Unfortunately I am developing it on a local server so there is no physical website yet. Maybe you could give me instruction.

    Thankyou

    Yes I show you with instructions.

    1. Edit the class of the button in the Mailchimp form code to what you see in this screenshot, https://www.dropbox.com/s/20wuthonx7588g0/2017-02-12.png?dl=0

    2. Delete the following css code from the style.css file (line 1150 to 1170)

    #mc-embedded-subscribe-form input[type="submit"],
    .ctct-embed-signup .ctct-button {
    background-color: #00aded;
    border: 0;
    color: #fff;
    display: inline-block;
    font-size: 1.071rem;
    font-weight: 400;
    text-transform: uppercase;
    text-decoration: none;
    cursor: pointer;
    margin-bottom: 20px;
    line-height: normal;
    letter-spacing: 2px;
    border-radius: 4px;
    }
    #mc-embedded-subscribe-form input[type="submit"]:hover,
    .ctct-embed-signup .ctct-button:hover {
    color: #333;
    background-color: #fff;
    }

    3. Delete the following code from the /inc/options.php file (line 411 and 412)

    #mc-embedded-subscribe-form input[type="submit"],

    Let me know if that works.

    I’ve followed your instruction and now the button has the correct border but for some reason the background of the button is grey and not transparent.

    Thanks for the help you have already given.

    Ah I may have forgotten one change.

    Add the following CSS to .btn-secondary on line 235 of the style.css file.

    background: transparent;

    So it should look like this,

    .btn-secondary {
        background: transparent;
        border-color: #e8e8e8;
        color: #e8e8e8;
        display: inline-block;
        text-decoration: none;
    }

You must be logged in to reply to this topic.